Skip to Main Content
Integration


This is an IBM Automation portal for Integration products. To view all of your ideas submitted to IBM, create and manage groups of Ideas, or create an idea explicitly set to be either visible by all (public) or visible only to you and IBM (private), use the IBM Unified Ideas Portal (https://ideas.ibm.com).


Shape the future of IBM!

We invite you to shape the future of IBM, including product roadmaps, by submitting ideas that matter to you the most. Here's how it works:

Search existing ideas

Start by searching and reviewing ideas and requests to enhance a product or service. Take a look at ideas others have posted, and add a comment, vote, or subscribe to updates on them if they matter to you. If you can't find what you are looking for,

Post your ideas
  1. Post an idea.

  2. Get feedback from the IBM team and other customers to refine your idea.

  3. Follow the idea through the IBM Ideas process.


Specific links you will want to bookmark for future use

Welcome to the IBM Ideas Portal (https://www.ibm.com/ideas) - Use this site to find out additional information and details about the IBM Ideas process and statuses.

IBM Unified Ideas Portal (https://ideas.ibm.com) - Use this site to view all of your ideas, create new ideas for any IBM product, or search for ideas across all of IBM.

ideasibm@us.ibm.com - Use this email to suggest enhancements to the Ideas process or request help from IBM for submitting your Ideas.


ADD A NEW IDEA

My subscriptions

Requesting to support MQ Multi Instance Managers

mq-qm-group behavior when multi-instance qmgrs are used in respective mq-qm objects. DataPower uses mq-qm objects which are active. This means that the qmgr is running and provides connectivity. However, multi-instance qmgrs provides connectivity ...
about 10 years ago in DataPower Gateway 0 Not under consideration

Enable full catalog-level synchronization in Config Sync for IBM API Connect

Currently, Config Sync can replicate APIs, products, and subscriptions between API Connect instances, but cannot synchronize entire catalogs including catalog definitions, properties.This limitation forces manual steps when creating or updating ca...
10 months ago in API Connect 0 Planned for future release

Certificate management when dealing with multiple objects

We have over 300 certs being used among multiple domains and need to have a better way to manage expiration and changes. We are requesting an enhancement to cert management in the following areas. An easy way to identify certs that are actually be...
about 3 years ago in DataPower Gateway 0 Future consideration

Add settings TCP_HOSTNAME_VERIFICATION_ALGORITHM for Event Streams Gateway

Hello team, could you please make setting of Hostname verification algorithm available via env variable TCP_HOSTNAME_VERIFICATION_ALGORITHM, just like there is TLS_VERSIONS? We actually wanted to use it to disable hostname verification on Event St...
over 1 year ago in IBM Event Automation / Event Endpoint Management 0 Not under consideration

ICAPS (secured ICAP) support

API gateway only supports ICAP today and it is not secured. This is for our existing customer and they have multiple different teams internally with different levels of security requirement. One of the teams need secured ICAP connectivity from the...
about 1 year ago in webMethods Integration/Microservices Runtime 0 Submitted

Expose DP's SSLClientProfile options "validate server hostname" and "hostname validation fail on error" to APICs TLS Profile

Due to PMR 89907,L6Q,000 a DataPower developer can now request that the Server Host Name be validated during SSL/TLS by selecting "Validate Server Hostname". This indicates whether to validate the host name in the Server Certificate.In addition, t...
over 6 years ago in API Connect 0 Future consideration

introspect url connection error with error different from 401

Currently APIGW doesn't support to return specific response due to fail to connect to the introspect url. From APIGW's point of view, fail to connect to the introspect url still belong to UnauthorizedError. I will prefer that in this case we have ...
over 2 years ago in DataPower Gateway 1 Future consideration

Configurable logging for Event Streams operator

The ES operators log ~10000 lines per hour and all of them are INFO, however, it shows many lines of detailed config information. We would like to get possibility to configure the logging or a way to decrease that output. For us it would also be o...
over 1 year ago in IBM Event Automation / Event Streams 1 Not under consideration

Integrate AMQ QMgr Error logs to IBM Web console

Hello, We are looking for the feasibility if AMQERRxx.LOG under Queue Manager can be integrated on IBM Web console. We don't need the history of maintaining the logs but good to have real time logs. It will be useful for MQ Admins to do troublesho...
about 1 year ago in MQ, MQ Advanced & MQ Appliance 0 Planned for future release

To remove whitelisted FQDN that are case sensitive used in the Gateway script

A domain url should not be case sentitive as a consumer point of view and it should not cause a invoked url to bricks. It just like entering ibm.com.sg and IBM.com.sg. It should redirect us to correct page.
almost 2 years ago in DataPower Gateway 0 Future consideration