Skip to Main Content
Integration


This is an IBM Automation portal for Integration products. To view all of your ideas submitted to IBM, create and manage groups of Ideas, or create an idea explicitly set to be either visible by all (public) or visible only to you and IBM (private), use the IBM Unified Ideas Portal (https://ideas.ibm.com).


Shape the future of IBM!

We invite you to shape the future of IBM, including product roadmaps, by submitting ideas that matter to you the most. Here's how it works:

Search existing ideas

Start by searching and reviewing ideas and requests to enhance a product or service. Take a look at ideas others have posted, and add a comment, vote, or subscribe to updates on them if they matter to you. If you can't find what you are looking for,

Post your ideas
  1. Post an idea.

  2. Get feedback from the IBM team and other customers to refine your idea.

  3. Follow the idea through the IBM Ideas process.


Specific links you will want to bookmark for future use

Welcome to the IBM Ideas Portal (https://www.ibm.com/ideas) - Use this site to find out additional information and details about the IBM Ideas process and statuses.

IBM Unified Ideas Portal (https://ideas.ibm.com) - Use this site to view all of your ideas, create new ideas for any IBM product, or search for ideas across all of IBM.

ideasibm@us.ibm.com - Use this email to suggest enhancements to the Ideas process or request help from IBM for submitting your Ideas.


ADD A NEW IDEA

DataPower Gateway

Support inline Deployment Policy and Deployment Policy Variables in REST Management import operations

Enhance REST Management import APIs to support inline Deployment Policies and Deployment Policy Variables in a manner equivalent to SOMA Import. SOMA Import supports defining and applying Deployment Policies and Deployment Policy Variables inline ...
3 days ago in DataPower Gateway Submitted

Probe in new UI is lacking critical filtering features that the old probe had/has

The new "gateway peering" probe currently lacks some filters/options to build triggers to limit whats being captured.This is important as the currently available settings are not sufficient to clearly capture relevant SOAP requests. The urgency of...
about 1 month ago in DataPower Gateway Submitted

DataPower Gateway Virtual Edition to make the version of vmware-tools visible for VMware VSphere.

 Hello,  We are running  DataPower Gateway Virtual Edition running on VMware vSphere. But the vmware vcenter can not see which version of vmware tool has been used. We can not check if the version is compliant.  VMware-tools ar...
4 days ago in DataPower Gateway Submitted

DataPower GitOps read/write reports a successful export but silently omits all symlinked local: content (e.g. local:///disk on disk-backed storage), producing incomplete config/file backups with no warning — making automated backup, DR and drift detection

We adopted DataPower GitOps (operation mode read/write) to automate backup of our domain configuration and local: files into Git as a single, trustworthy config-as-code pipeline for backup, disaster recovery and drift detection. We found that on a...
20 days ago in DataPower Gateway Submitted

Extended Debug Information for Inbound HTTPS Connections

When troubleshooting inbound HTTPS connections, the debug output currently does not expose sufficient certificate metadata (e.g. subject, issuer, validity period, chain verification result). Only the server information is displayed. We would like ...
about 2 months ago in DataPower Gateway Submitted

Truststore support on certificate objects

Currently, certificates are managed per MultiProtocol Gateway and each certificate has its own object and does only read the first certificate of a given file. We would like to explore a truststore like support for the certificate objects. So that...
about 2 months ago in DataPower Gateway Submitted

Enable the "draft 7" json compiler, found in V11.0.0.2 and later firmware, for all schema draft versions

We have seen limited good results by forcing the draft 4 schema to appear as draft 7 which used the "new compiler".  We want an "opt-in" configuration to enable the "new compiler" to be available as the compiler for all schemas.  This wi...
about 1 month ago in DataPower Gateway Submitted

Native HTTP QUERY Method Support Across IBM Infrastructure

Requesting native support for the HTTP QUERY method (RFC 10008) across IBM's gateway and runtime portfolio — including DataPower Gateway and API Connect to enable safe, idempotent HTTP requests that carry a structured request body. This capability...
about 2 months ago in DataPower Gateway Submitted

Make TLS setting configurable for TLS SNI Sever Profile

TLS Server profile config options like ciphers, signature algorithms, curves, and KEMs should be configurable for TLS SNI Server profiles as well, or should be inherited from linked TLS Server profile. If not, no one with the need of SNI profiles,...
3 months ago in DataPower Gateway Submitted

We would like for traditional DataPower services to support JSON RFC 7159 when setting request and/or response type to JSON

At the moment the request and response type settings in traditional DataPower services like Multiprotocol Gateway and Web Service Proxy support JSON RFC 4627 when choosing request and/or response type JSON. For more recent services with a JSON pay...
7 months ago in DataPower Gateway Future consideration